Netflix: Fix Missing Component Error Code M7357-1003

If you are using Google Chrome to watch a show on Netflix and receive error that says “Whoops,. something went wrong… Missing Component. Error code M7357-1003“, give these steps a try to fix the issue.

Netflix something went wrong missing component


Fix 1 – Enable Widevine Plugin

  1. Type “chrome://components/” in the Chrome address bar, then press “Enter“.
  2. Find the “Widevine Content Decryption Module” and select “Check for update” button.

If the plugin updates, see if this solves your issue.


Fix 2 – Clear WidevineCDM folder

Windows

  1. Hold the Windows Key and press “R” to bring up the Windows Run dialog.
  2. Type “%userprofile%\appdata\Local\Google\Chrome\User Data” without quotes, then select “OK“.
  3. Delete the “WidevineCdm” folder.
  4. Type “chrome://components/” in the Chrome address bar, then press “Enter“.
  5. Find the “Widevine Content Decryption Module” and select “Check for update” button.

Mac

  1. Hold the “Option” key and select “Go“.
  2. Choose “Library
  3. Navigate to “Application Support” > “Google” > “Chrome“.
  4. Delete the “WidevineCDM” folder.
  5. Bring up Chrome, and type “chrome://components“, then press “Enter“.
  6. Select the “Check for update” button under “WidevineCdm“.

Fix 3 – Uninstall Then Reinstall Chrome

If none of the above tricks solve this error for you, uninstalling then reinstalling Google Chrome will often fix it. Follow the steps for your operating system to uninstall Google Chrome. After it is fully uninstalled, download and install a fresh copy.


Hopefully one of the three fixes above helped you solve the error code M7357-1003 in Netflix on Chrome. Please feel free to share your experience in the comments section below.

4 thoughts on “Netflix: Fix Missing Component Error Code M7357-1003”

  1. Firefox is our primary source for streaming on a laptop. Now it won’t stream anymore, and we need help getting a new plug in.

    Please help me fix my streaming problem.

    Reply
  2. well i guess i dont get it-ive done all the suggestions that have been offered–everyone is so help bent on updating the widevine folder–even deleting the folder- and then they close their post with “that ought to fix it” has anyone looked in the WV folder–exactly–theres nothing in it to fix-so it’ll never update–so learning how to update is 2nd to finding it somewhere to download the whole module–thats the problem!

    Reply
    • i have a PS…again i know nothing about computers but i found the widevine file–no no nopt the empty on when you type Type “%userprofile%\appdata\Local\Google\Chrome\User Data”.. if you looked that folder is empty.. i found a full folder buried deep in C:/ but i dont know what to do with it- check it out -then tell me what to do next- thanks

      .C:\ProgramFilesx86)\Google\Chrome\Application\91.0.4472.164\WidevineCdm\_platform_specific\win_x64
      then you’ll see
      widevinecdm.dll sig 2kb 7/14/2021 12:14pm
      widevinecdm dll 10,125kb 7/14/2021 12:14pm

      Reply

Leave a Reply to BENT VON SCHOLTEN Cancel reply